首页 » Linux » Configure » Linux-libvirt3.2 升级4.1

Linux-libvirt3.2 升级4.1

 

记一次,libvirt升级操作
libvirt3.2 升级4.1

rpm -qa libvirt

yum remove libvirt

wget https://libvirt.org/sources/libvirt-4.1.0.tar.xz

xz -d libvirt-4.1.0.tar.xz

tar xvf libvirt-4.1.0.tar.xz

yum install libnl-devel
#error: libxml2 >= 2.6.0 is required for libvirt
yum install libxml*

#configure: error: You must install the libyajl library & headers to compile libvirt
yum install yajl-devel

#configure: error: You must install device-mapper-devel/libdevmapper to compile libvirt with mpath storage driver

yum install device-mapper-devel

#configure: error: You must install the pciaccess module to build with udev
yum install libpciaccess-devel
#完成
#configure: DTrace: no
#configure: numad: no
#configure: XML Catalog: /etc/xml/catalog
#configure: Init script: systemd
#configure: Char device locks: /var/lock
#configure: Default Editor: vi
#configure: Loader/NVRAM:
#configure: virt-login-shell: yes
#configure: virt-host-validate: yes
#configure: TLS priority: NORMAL
#configure:
#configure: Developer Tools
#configure:
#configure: wireshark_dissector: no
#configure:
#configure: Privileges
#configure:
#configure: QEMU: root:root
#configure:

#错误:将插槽连接到 ‘/usr/local/var/run/libvirt/libvirt-sock’ 失败: 没有那个文件或目录
解决方法:
ln -s /var/run/libvirt/libvirt-sock /usr/local/var/run/libvirt/libvirt-sock

原文链接:Linux-libvirt3.2 升级4.1,转载请注明来源!

1